World Boss

Discussion in 'Feedback' started by Ryuuzaki, Aug 28, 2018.

  1. Ryuuzaki

    Ryuuzaki New Member

    Joined:
    Oct 26, 2017
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    hi could you make it to where you can have a hide player button in world boss i lagg and freeze so bad because of all the outfits and wing animations thank you
     
  2. Bonnie

    Bonnie Active Member Staff Member Moderator

    Joined:
    Apr 5, 2016
    Messages:
    474
    Likes Received:
    136
    Trophy Points:
    43
    Gender:
    Female
    go into world boss Manually and after you die press the auto fight button.
     
  3. Artemisia

    Artemisia Member Moderator

    Joined:
    Apr 15, 2018
    Messages:
    102
    Likes Received:
    9
    Trophy Points:
    18
    Hi next to the mail is hide players eye, up by the mini map, click that will hide players for you.
     
  4. Ryuuzaki

    Ryuuzaki New Member

    Joined:
    Oct 26, 2017
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    even if you click the hide players eye it still doesnt work when you go into worldboss
     
  5. Artemisia

    Artemisia Member Moderator

    Joined:
    Apr 15, 2018
    Messages:
    102
    Likes Received:
    9
    Trophy Points:
    18
    ok well for a better gaming experience I suggest you go to settings and press auto configure and then save. This will take away all skill effects and page shake, it might help you be less laggy.
     
  6. Ryuuzaki

    Ryuuzaki New Member

    Joined:
    Oct 26, 2017
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    i always hide everything the problem is all these people with huge flashy wings and mounts is what causes lagg that is the case in many online game